Всё о массивах в 1С: для чего нужны и как с ними работать

Содержание

Изучаем массивы в 1С 8.3 (8.2)

Всё о массивах в 1С: для чего нужны и как с ними работать

Массив в платформе 1С 8.3 это самая простая универсальная коллекция значений.

Что такое Массив?

Массив в языке программирования 1С — это коллекция элементов, следующих друг за другом, которые могут быть доступны с помощью индекса массива. Элементы могут быть любого типа, в том числе и типа Массив. У каждого элемента в массиве есть уникальный номер, который называют Индексом. Посредством индекса можно получить доступ к данному элементу.

Все элементы в массиве упорядочены, т.е. первый элемент имеет индекс, равный нулю, второй — одному, и так далее.

Создать массив можно при помощи конструктора Новый

Новый Массив (…)

Где:

«КоличествоЭлементов» — необязательный параметр. Он может быть один — тогда мы будем иметь одномерный массив, а также их может быть несколько — тогда мы имеем многомерный массив.

Например,

Массив1 = Новый Массив(10);

— Одномерный массив из 10 элементов.

А:

Массив1 = Новый Массив(3,2);

Двумерный массив из 6 элементов (три строки, два столбца).

Или

Массив1 = Новый Массив();

Массив, не имеющий ни одного элемента, — пустой массив.

В отличие от таблиц значений 1С, работать с массивами можно как в режим тонкого клиента, так и в режим толстого клиента.

Имейте в виду, что когда Вы создадите не пустой массив (одномерный или многомерный), его элементы уже будут существовать, но с не заполненными значениями. Если Вы посмотрите на данный массив в отладчике, то увидите напротив каждого элемента тип Неопределено.

Обращаться к элементу массива можно посредством индекса. Делается это с помощью оператора «квадратные скобки».

Массив1[0] = «Первый»;
Массив1[1] = 2;

Как видите, элементы массива могут иметь разные типы ( в том числе ссылочные).

При помощи индекса и квадратных скобок можно как задать какой-то элемент массива, так и прочитать этот элемент.

Сообщить(«Массив1[0]= » + Массив1[0] +
«, Массив[1] = » + Массив1[1]);

Индекс внутри скобок не должен превышать общего количества элементов минус один (т.к. индекс начинается с нуля).  Если мы напишем такой код:

Массив1 = Новый Массив(5);
Массив1[5] = 10;

То при его выполнении, возникнет ошибка «Индекс находится за границами массива»

Хоть мы и указали у конструктора массивов в скобках значение 5, но обращаться может только до 4 индекса, поскольку нумерация индексов начинается с нуля.

Перебор элементов массива

Перебрать все элементы массива можно двумя способами.  Первый способ – с помощью так называемого «китайского кода», когда присваиваем каждому элементу массива нужное значение. Иногда это бывает необходимо.

Сообщить(Массив[0]);
Сообщить(Массив[2]);
Сообщить(Массив[1]);

Но чаще необходимо прочитать каждый элемент массива в цикле. Для этого в теле цикла нужно обойти индексы от первого до последнего. Сделать это можно при помощи цикла Для…Цикл.

Массив1 = Новый Массив(3);
Массив1[0] = 10;
Массив1[1] = 3;
Массив1[2] = 7;
Для н = 0 по 2 Цикл
    Сообщить(Массив1[н]);КонецЦикла;

Или с помощью цикла Для каждого … Цикл

Для Каждого ЭлМассив из Массив1 Цикл
    Сообщить(ЭлМассив);
КонецЦикла;

Где в переменной ЭлМассив для каждой итерации содержится соответствующее значение элемента массива.

Количество элементов массива

Узнать количество элементов массива можно двумя способами.  С помощью метода Количество() и метода ВГраница(). Метод Количество() возвращает количество элементов массива (т.е.

то число, что задается в скобках конструктора массива), а метод ВГраница() самый максимальный индекс элемента массива или граница массива.

  В этом случае перебор элементов массива в цикле возможен двумя способами.

Для н = 0 по Массив1.Количество() — 1 Цикл
    Сообщить(Массив1[н]);
КонецЦикла;

И

Для н = 0 по Массив1.ВГраница() Цикл
    Сообщить(Массив1[н]);
КонецЦикла;

Второй способ считается более правильным.

Добавление элементов массива

Добавить элемент массива можно с помощью методов Добавить() и Вставить(). Первый метод добавляет элемент в конец массива, а второй вставляет элемент в нужный индекс массива.

Массив1 = Новый Массив();
Массив1.Добавить(10);
Массив1.Вставить(0,20);
Массив1.Добавить(5);

В этом коде мы создали пустой массив, потом добавили элемент (он же первый), потом вставили на нулевой индекс элемент, а потом добавили. Должен получиться следующий результат.

Многомерный массив

Многомерным массивом в языке программирования 1С называется массив, элементами которого являются массивы. Если одномерный массив создавался посредством конструктора с одним параметром, то в многомерном массиве может быть два и больше параметров.

МассивМн1 = Массив(3,2,5);

В этом примере мы создали массив, у которого будет три элемента, каждый из которых будет массивом, содержащим по два массива, в каждом из которых будет пять элементов.

Например, создадим двумерный массив:

МассивМн1 = Новый Массив(3,2);
Для  н = 0 По МассивМн1.ВГраница() цикл
    МассивВнутренний = МассивМн1[н];
    Для к = 0 по МассивВнутренний.ВГраница() цикл
        МассивВнутренний[к] = Строка(н+1)+ «.» + Строка(к+1);    КонецЦикла;

КонецЦикла;

А вывод в окно сообщений следующим образом

Для Каждого ЭлМассиваВнеш из МассивМн1 цикл
    СтрокаВывода = «»;
    Для Каждого ЭлемМассиваВнутр из ЭлМассиваВнеш цикл
          СтрокаВывода = СтрокаВывода + » » + ЭлемМассиваВнутр;    КонецЦикла;Сообщить(СокрЛ(СтрокаВывода));КонецЦикла;

Статьи о других универсальных коллекциях значений в 1С

Соответствия в 1С

Список значений в 1С

Таблица значений 1С

Структура в 1С

Более подробно о работе с массивами и другими интересными объектами языка программирования в 1С читайте в моей книге «Программировать в 1С за 11 шагов»

Книга «Программировать в 1С за 11 шагов»

Изучайте программирование в 1С в месте с моей книги «Программировать в 1С за 11 шагов»

  1. Книга написана понятным и простым языком — для новичка.
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Научитесь понимать архитектуру 1С;
  4. Станете писать код на языке 1С;
  5. Освоите основные приемы программирования;
  6. Закрепите полученные знания при помощи задачника;

Книга «Основы разработки в 1С: Такси»

Отличное пособие по разработке в управляемом приложении 1С, как для начинающих разработчиков, так и для опытных программистов.

  1. Очень доступный и понятный язык изложения
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Поймете идеологию управляемого приложения 1С
  4. Узнаете, как разрабатывать управляемое приложение;
  5. Научитесь разрабатывать управляемые формы 1С;
  6. Сможете работать с основными и нужными элементами управляемых форм
  7. Программирование под управляемым приложением станет понятным

Промо-код на скидку в 15% — 48PVXHeYu

Если Вам помог этот урок решить какую-нибудь проблему, понравился или оказался полезен, то Вы можете поддержать мой проект, перечислив любую сумму:

можно оплатить вручную:

Яндекс.Деньги — 410012882996301
Web Money — R955262494655

Вступайте в мои группы:

: https://.com/1c_prosto
Фейсбуке: https://www..com/groups/922972144448119/
ОК: http://ok.ru/group/52970839015518
Твиттер: https://.com/signum2009

Источник: https://www.1s-up.ru/izuchaem-massivy-v-1c-8-3-8-2/

Работа с массивами в 1С 8

Всё о массивах в 1С: для чего нужны и как с ними работать

Массив в 1С — это набор некоторых значений. Значения в одном массиве могут быть различных типов.

Массив может быть получен в результате выполнения различных функций, например, ВыгрузитьКолонку() таблицы значений; в виде массива можно получить выделенные строки динамического списка и т.д. Можно создать массив и «вручную».

1. Как создать массив нужного размера

пМассив = новый Массив(4); //создали массив из 4 элементов

//Внесем значения элементов массива

пМассив[0] = “Мы”;

пМассив[1] = “создали”;
пМассив[2] = “новый”;
пМассив[3] = “массив”;

2. Как создать пустой массив и добавить в него элементы

пМассив = новый Массив; //создали пустой массив

//Внесем значения элементов массива

пМассив.Добавить(“Мы”);

пМассив.Добавить(“создали”);
пМассив.Добавить(“новый”);
пМассив.Добавить(“массив”);

3. Как создать многомерный массив

Рассмотрим этот вопрос на примере двумерного массива, так как массивы больших размерностей используются значительно реже, а механизм их работы не отличается от двумерного.

пМассив = новый Массив (4, 2); //создали  массив 4х2

//Внесем значения элементов массива, пронумеровав каждое слово

пМассив[0][0] = “1. “;

пМассив[0][1] = “Мы”;
пМассив[1][0] = “2. “;
пМассив[1][1] = “создали”;
пМассив[2][0] = “3. “;
пМассив[2][1] = “многомерный”;
пМассив[3][0] = “4. “;
пМассив[3][1] = “массив”;

4. Как создать фиксированный массив

Фиксированный массив отличается от обычного тем, что его нельзя изменять. Нельзя добавлять, удалять или менять значения элементов такого массива.

Фиксированный массив может быть получен из обычного:

пМассив = новый Массив;

пМассив.Добавить(“Мы”);

пМассив.Добавить(“создали”);
пМассив.Добавить(“новый”);
пМассив.Добавить(“массив”);

фМассив = новый ФиксированныйМассив(пМассив); // создали фиксированный массив

Функции работы с массивами

Работу функций будем рассматривать на примере одномерного массива пМассив, созданного выше и состоящего из 4 элементов:

  1. «Мы»
  2. «создали»
  3. «новый»
  4. «массив».

Функция ВГраница()

Получает наибольший индекс элемента массива. Он всегда на единицу меньше количества элементов массива.

Индекс = пМассив.ВГраница() // 3;

Функция Вставить()

Вставляет какое-то значение в элемент массива с указанным индексом. Последующие элементы массива сдвигаются

пМассив.Вставить(3, “новое значение”) //Теперь массив состоит из 5 элементов

Функция Добавить()

Создает новый элемент в конце массива и вставляет туда заданное значение

пМассив.Добавить(“.”) // добавили точку пятым элементов массива;

Функция Количество()

Возвращает количество элементов массива.

пМассив.Количество(); // 4

Функция Найти()

Ищет в массиве заданный элемент. Если находит, возвращает его индекс. Если не находит, возвращает Неопределено.

Индекс = пМассив.Найти(“массив”); // 3
Индекс = пМассив.Найти(“строка, которой не было”); // Неопределено

Функция Очистить()

Удаляет все значения из массива.

Функция Получить()

Получает значение массива по индексу. Эту же задачу можно решить через [].

Значение=пМассив.Получить(3) // “массив”
Значение=пМассив[3]; // “массив”

Функция Удалить()

Удаляет элемент массива по индексу

Функция Установить()

Устанавливает значение элемента массива по индексу. Работает аналогично [].

пМассив.Установить(3, “массив!”);
пМассив[3]=”массив!”;

Как обойти массив

Можно обойти все элементы массива без указания индекса:

Для каждого ЭлементМассива из пМассив Цикл
Сообщить(ЭлементМассива);
КонецЦикла;

Можно при обходе использовать индекс:

Для Индекс=0 по пМассив.ВГраница() Цикл
Сообщить(пМассив[Индекс]);
КонецЦикла;

Как обойти многомерный массив

Многомерный массив обходится с помощью тех же циклов (см. выше), но один цикл должен быть вложен в другой.

мМассив=новый массив(3,4);

Для каждого Элемент1 из мМассив Цикл

Для каждого Элемент2 из Элемент1 Цикл
Сообщить(Элемент1);
КонецЦикла;
КонецЦикла;

Или с применением индексов.

мМассив=новый массив(3,4);

Для Индекс1=0 по мМассив.ВГраница() Цикл

Для Индекс2 по мМассив[Индекс1].ВГраница() Цикл
Сообщить(мМассив[Индекс1][Индекс2]);
КонецЦикла;
КонецЦикла;

Сортировка массива

Для сортировки массива нам потребуется вспомогательный объект с типом СписокЗначений.

СписокЗнач = новый СписокЗначений; // создаем список значений
СписокЗнач.ЗагрузитьЗначения(пМассив); // загружаем в список значения из массива
СписокЗнач.СортироватьПоЗначению(НаправлениеСортировки.

Возр); //сортируем по возрастанию
СписокЗнач.СортироватьПоЗначению(НаправлениеСортировки.Убыв); //или по убыванию
пМассив=СписокЗнач.

Выгрузить(); // выгружаем отсортированные значения обратно в массив

Сравнение двух массивов

Перед тем, как перейти к описанию функции сравнения, договоримся, что массивы считаются идентичными, если имеют одинаковое количество элементов и соответствующие элементы массивов равны. Тогда для сравнения можно использовать следующую функцию (кстати, такая функция уже присутствует в некоторых типовых конфигурациях):

Функция СравнитьМассивы(Массив1, Массив2)

Если Массив1.Количество()Массив2.Количество() Тогда

Возврат ЛОЖЬ; // Массивы не равны, сравнивать элементы нет смысла.
КонецЕсли;

Для Индекс=0 по Массив1.ВГраница() Цикл

Если Массив1[Индекс]Массив2[Индекс] Тогда
Возврат Ложь; //эти элементы не равны, значит и массивы не равны
КонецЕсли;
КонецЦикла;

Возврат Истина; // Если дошли до сюда, то массивы равны

КонецФункции

В функцию нужно передать 2 сравниваемых массива. Функция возвращает значение Истина, если массивы равны, и Ложь, если не равны.

Источник: http://chel1C.ru/%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%B0-%D1%81-%D0%BC%D0%B0%D1%81%D1%81%D0%B8%D0%B2%D0%B0%D0%BC%D0%B8-%D0%B2-1%D1%81-8/

Программы 1С: что это и для чего используются?

Всё о массивах в 1С: для чего нужны и как с ними работать

Современный прогресс IT-технологий начинает постепенно захватывать каждую сферу нашей обыденной жизни. Если развлечение, обучение и творчество ‒ это понятные и логичные сферы развития, то вот бизнес и IT-технологии ‒ это уже что-то новое. Да, предпринимательство – довольно сложная и постоянно изменяющаяся сфера нашего мира.

Долгое время в этой сфере преобладала документация, которая исчислялась тоннами и постоянно мешала нормально реагировать на изменения, так как приходилось тратить огромное количество времени на поиск нужной информации и ее редактирование.

Но все изменилось, когда прогресс программных технологий ворвался в эту сферу, представив предпринимателям уникального и универсального помощника 1С. Отсюда и возникает вопрос “Программы 1С, что это?”.

Как ими пользоваться? Можно ли получить от этого пользу? Пришло время разобраться во всех нюансах, которые касаются этой программы, и наконец-то понять, стоит ли переходить на нее. В этой статье имеется вся информация, которая позволит вам не только понять сущность утилиты, но и выбрать помощников для своего бизнеса.

Что это за программа?

Программы 1С, что это за утилиты? Прежде чем углубленно изучать данный вопрос, стоит разобраться в предназначении программы и ее определении. 1С – это мощный комплекс программ, который позволяет намного облегчить различные стороны вашего бизнеса, будь то продажи, услуги, контроль за персоналом и т. д.

Пакет утилит этого назначения имеет уникальную структуру программирования, которая позволяет без проблем манипулировать информацией в бизнесе и контролировать каждую серу своей деятельности.

Говоря простым языком, вы сможете автоматизировать мыслительный и учетный процесс своей компании, что снизит нагрузку на персонал и увеличит эффективность деятельности.

Зачем она нужна?

Работа в программе 1С позволит структурировать данные компании и вести более точный и тщательный учет деятельности. К примеру, сфера продаж подразумевает постоянные проверки и регулировку продукции.

Сделать это вручную и с помощью бюрократии довольно сложно, а с помощью интерактивного подхода организовать и реализовать этот процесс довольно-таки просто.

Благодаря понятному интерфейсу, огромным возможностям и слаженной работе практическую любую деятельность компании можно подогнать под определенный шаблон и эффективно им руководствоваться.

Помимо учета и контроля программа позволяет составлять отчеты, создавать налоговую отчетность и тут же ее отправлять в специальные учреждения. В общем, перечислить все возможности программы довольно сложно. Но стоит отметить, что она точно вам пригодится, если у вас имеется свое дело.

Разновидности утилиты

Программы 1С, что это за пакет утилит? Какие есть отличительные особенности у них? На самом деле существует только одна основная программа, «1С: Предприятие», которая может включать в себя различные прикладные решения. К примеру, бухгалтерская программа 1С, зарплата персонала, управление человеческими ресурсами и т. д.

На данный момент существует несколько десятков различных прикладных решений, которые предназначены для той или иной деятельности. И, что самое интересное, они не перестают пополняться. Стало это возможно благодаря специальной лицензии на внесение изменений и программирование утилит, которую распространяет сама компания 1С.

Так что вы сами можете вносить необходимые изменения и настраивать все составляющие программы в таком виде, который вам удобен и необходим.

Сложно ли она в плане использования?

Что же имеет программа 1С? Проводки, различные нюансы, установки, настройки, правила и многое другое. Данный пакет программ содержит огромное количество различных элементов, которые, в свою очередь, требуют от пользователя огромного багажа знаний.

Сесть и разобраться самому в программе не получится, и для получения особых навыков и качественных знаний самообучение не поможет. Нужно специализированное и целенаправленное получение этих навыков.

Утилита сложна в освоении, но при наставничестве профессионала и постоянной практике обучиться пользоваться ей возможно. Но стоит учитывать, что сразу все постичь не получится.

На данный момент существует множество образовательных программ, которые обучают по специальным направлениям, и в основном в них входят прикладные решения: бухгалтерская программа 1С, управление персоналом, программирование установок, управление малым предприятием и т. д.

Кто может ей пользоваться?

Только специалисты могут ответить и разъяснить, как работать в программе 1С. Именно из-за трудностей освоения работы в этой программе нужны профессионалы, которые прошли обучение или имеют обширный опыт пользования ею. Благодаря их навыкам и знаниям они смогут настроиться на эффективную деятельность, а вы получите положительный результат.

Что насчет документации, которую имеет программа 1С? Инструкция, предоставляемая вместе с этой утилитой, вряд ли может помочь какими-то особыми знаниями. Поэтому не стоит экономить и рисковать, а лучше обратиться к специалистам.

А если вы являетесь тем, кто хочет получить все эти навыки, то стоит подыскать учреждения, которые предоставят вам возможность пройти специальные курсы обучения. Но даже в этом случае не стоит надеяться на то, что вы сразу станете гением в области 1С.

Обучение даст вам базовые навыки, которые в дальнейшем нужно будет расширять и улучшать на практике.

Гибкость и универсальность

Собственно, как работать в программе 1С, мы разобрались. Точнее, ознакомились с установкой, которая необходима для получения навыков. Теперь осталось рассмотреть плюсы этого пакета утилит.

Как мы отмечали выше, 1С позволяет покупателям самим регулировать программу таким образом, чтобы было удобнее пользоваться.

Благодаря программистам вы можете создать из «1С: Предприятие» удобного и необходимого помощника для вашего бизнеса, который позволит эффективно вести учет ресурсов, управлять персоналом, развиваться и хранить все необходимые данные о вашей компании.

Универсальность программы заключается в том, что она имеет абсолютно все то, что нужно для успешного управления бизнесом. Пакет утилит 1С внедрился практически в каждую компанию, и сегодня каждая вторая фирма активно использует эту программу для своего успешного функционирования.

Постоянная поддержка

Следующей особенностью 1С является постоянная поддержка разработчиков, которые в случае поломки, вопросов и других неприятных ситуаций готовы оказать помощь.

Они могут организовать консультацию и починку вашего продукта, если произошла неприятная ситуация или технический сбой.

Правда, прежде чем обращаться за поддержкой, стоит внимательно ознакомиться с пользовательским соглашением, которое регулирует все стороны процесса. Благодаря этому вы будете знать и свои права, и обязанности со стороны разработчиков.

1С – важный инструмент бизнеса

Программы 1С ‒ что это? Это обязательный инструмент ведения успешного дела. Благодаря ей можно учитывать каждый элемент, каждую операцию своей компании.

Кроме того, она позволяет составлять планы, создавать стратегии развития и выяснять, где же кроется слабость в структуре вашей компании.

1С – это удобный помощник в вашем бизнесе, который будет контролировать всю ситуацию в компании и умещать ее на небольшом пространстве вашего компьютера, тем самым заменяя целые архивы документации.

Источник: https://FB.ru/article/198032/programmyi-s-chto-eto-i-dlya-chego-ispolzuyutsya

Всё о массивах в 1С: для чего нужны и как с ними работать

Всё о массивах в 1С: для чего нужны и как с ними работать

В программе 1С можно создавать массивы и использовать функции, связанные с ними. Благодаря этому вы сумеете упорядочить элементы и будете обращаться к ним по индексу. Чтобы работать с коллекциями значений, надо разбираться в программировании.

Ведь все данные придётся вводить вручную — без графического интерфейса, кнопок или диалоговых окон. Например, чтобы преобразовать в 1С массив в строку и разделить её на группу подстрок, используют операторы, которые входят в синтаксис утилиты.

Для этого нужно хотя бы общее представление об алгоритмах.

Применение массивов в 1С помогает упорядочить используемые в работе элементы.

О массивах

Это программный набор элементов. Он служит для:

  • Отбора значений.
  • Сортировки. Каждой позиции в массиве присваивается индекс. Это облегчает поиск. И вы можете сослаться на объект, написав его номер.
  • Объединения и сохранения записей.
  • Разделения групп, создания подстрок.
  • Массив — сам по себе объект. К нему будет привязана переменная. Можно обратиться к отдельным его частям или использовать его целиком в процедурах. Например, можно объединить группу значений «Сотрудники отдела N» и внести туда имена и фамилии работников.

Проведём аналогию. Представьте книжный шкаф. Книги в нём расставлены по разным «ячейкам». Если вести учёт, вы будете знать, где находится каждый объект. И без труда его достанете. Но если книги, журналы и газеты хаотично разбросаны на столе, поиск нужной вещи затянется. Хотя это не отражает все возможности уникальных коллекций.

Создание

Работа с массивами 1С начинается с их создания. Нужно «место действия» — поле, в котором вы будете вводить код.

  1. Откройте «Конфигуратор» («Конфигурация»).
  2. Кликните правой кнопкой мыши по пункту «Обработка».
  3. Выберите «Добавить».
  4. Появится подменю «Обработка1». Выделите его. Информация о нём отобразится в рабочей области.
  5. На вкладке «Основные» введите «Имя». Скажем, «ТестовыйМассив».
  6. Откройте раздел «Формы».
  7. Нажмите на значок в виде лупы.
  8. Отметьте опцию «Форма обработки».
  9. Щёлкните на «Готово».
  10. Откроется окно с тремя фреймами. В правом верхнем перейдите в закладку «Команды».
  11. Иконка в виде плюса, чтобы добавить позицию.
  12. Появится пункт «Команда1». Выделите его.
  13. В поле «Имя» введите название. К примеру, «ТестовыеЗначения». Скопируйте его в «Заголовок».
  14. В строке «Действие» нажмите на лупу.
  15. Пункт «Создать на клиенте» и «OK».
  16. Вот и модуль, в котором можно вводить код.

Чтобы выводить промежуточный результат, создайте «кнопку». Зачем она нужна в массиве — вы поймёте чуть позже.

  1. Перейдите на вкладку «Формы». Она внизу.
  2. Щёлкните правой кнопкой мыши на «Командная панель».
  3. «Добавить — Кнопка».
  4. Придумайте ей любое название. Или можете оставить то, которое выдано по умолчанию.
  5. В поле «Имя команды» нажмите на пиктограмму в виде многоточия.
  6. Выберите «ТестовыеЗначения». Если назвали команду по-другому, там будет иной заголовок.

Теперь можно приступать к работе с коллекциями. Но не думайте, что в 1С сразу сможете разложить строку в массив. Лучше начать с чего-нибудь полегче. Хотя все функции — это набор операторов, которые надо просто запомнить.

  1. Откройте закладку «Модуль».
  2. Текст, который идёт после двух косых чёрточек (два слеша — «//») можно удалить. Он выглядит примерно так «// Вставить содержимое обработчика». Это пояснения. Их пишут программисты, чтобы не запутаться в коде.
  3. Свой текст пишите между операторами «Процедура» и «КонецПроцедуры».
  4. Теперь создайте набор значений. Придумайте переменную, которая будет условно его обозначать. Допустим, «ПервыйМассив».
  5. Её надо связать с объектом. Для этого введите команду «ПервыйМассив = Новый массив ()». Это коллекция, в которой может быть неограниченное количество элементов. Если у вас фиксированный размер, укажите его после команды в скобках «Новый массив (5)». Соответственно, двумерная коллекция будет выглядеть «Новый массив (7, 5)». Можно создавать многомерные наборы.
  6. При вводе могут появиться подсказки, которые предлагают подходящие операторы.
  7. Слова различаются по цвету. У переменных одна расцветка, у функций — другая.
  8. После каждой команды ставьте точку с запятой «;». И для удобства начинайте с нового абзаца.
  9. С пустым множеством ничего сделать нельзя. Ни упорядочить, ни вывести, ни разложить строку в массив в 1С. Поэтому надо вставить в него элементы.
  10. Введите «ПервыйМассив.Добавить(Значение1);». Потом «ПервыйМассив.Добавить(Значение2);» и так далее.
  11. Объекты нумеруются с нуля. То есть переменной «Значение1» будет присвоен индекс «0». Можете сами заполнять коллекцию со «Значение0», чтобы не перепутать.

Для чего всё это? И зачем та загадочная «кнопка»? Попробуем запустить простенькую функцию.

  1. Под коллекцией напишите команду «Сообщить (ПервыйМассив[0]);» В квадратных скобках указан индекс элемента. То есть адрес нашего «Значение0».
  2. Отформатируйте модуль. Это проверка на наличие ошибок. В больших блоках можно что-то недоделать по невнимательности: не поставить точку с запятой, не закрыть скобку, неправильно написать переменную. Компилятор на это укажет.
  3. Нажмите на кнопку в виде знака «Плей» (треугольник в круге), чтобы запустить написанную вами программу.
  4. Кликните на «Сервис» и выберите вашу кнопку.
  5. Нажмите её.
  6. Появится надпись «Значение0». Это и есть результат выполнения функции.

Показана самая простая операция, чтобы вы поняли, как вообще работают массивы. С ними можно создавать сложные и многоуровневые программы. Выводить объекты, сортировать, удалять повторы, разбивать на набор подстрок, объединять, разделять, искать сведения. Нужно лишь знать операторы.

Функции

Все доступные функции есть в справочнике программы. Перечислим несколько, чтобы показать принцип.

Как превратить массив 1С в строку:

ТестМассив = Новый Массив(4);ТестМассив[0] = Это;ТестМассив[1] = Делается;ТестМассив[2] = Так;СтрокаТест = ЗначениеВСтрокуВнутр(ТестМассив);

Сообщить(СтрокаТест);

Выводите на «Кнопку» и получаете фразу. Это может быть частью большого модуля — в таком случае оператор «Сообщить» не нужен.

Чтобы в 1С разложить строку в массив подстрок, нужен разделитель. Условная метка, после которой текст будет делиться. Допустим, есть слово «Протокол». И мы поставим разделитель «О». Введите команду «ТестМассив = РазложитьСтрокуВМассив(Протокол, «О») ;» Получится отдельно «Пр», «Т», «К» и «Л». Разделитель стёрт. А слово разделено на несколько подстрок.

Вот как это можно применить на практике. У вас есть массив с ФИО сотрудников. И вам нужно, чтобы при выборе позиции автоматически заполнялись поля «Фамилия», «Имя» и «Отчество». Для этого ФИО надо разбить на три составляющих. В качестве разделителя используйте «пробел».

Обычно для этого используется сложный модуль: цикл с большим количеством операторов. Циклические блоки с условием строятся по принципу «Если (условие), тогда (действие1), иначе (действие2)». Вначале программа проверяет, выполняется ли условие. Если да, то она запускает первую функцию. Если нет — вторую.

Цикл проверит каждый символ в строке. Если там нет разделителя, он продолжает дальше. Если там есть разделитель, он добавляет значение в набор подстрок. Там могут использоваться и другие операторы: к примеру, «СокрЛП» — сокращение определённых знаков справа и слева от строки.

Каждый модуль надо «заканчивать», чтобы утилита прекратила выполнение процедуры. На цикле с «Если» этот оператор — «КонецЕсли». На цикле без условий — «КонецЦикла». Каждую функцию надо отдельно завершать.

Поиск и сортировка

В коллекциях может находиться огромное количество данных. Надо научиться их искать и сортировать.

Чтобы запустить поиск в массиве в 1С, используйте оператор «Найти». Отыскать нужное значение можно и визуально. Но если там сотни элементов, лучше создать дополнительный модуль и запустить подпрограмму. Покажем на примере простой функции. Но это подойдёт для любых блоков.

МассивТест = Новый Массив(3);МассивТест[0] = «Телефон»;МассивТест[1] = «Ноутбук»;МассивТест[2] = «Компьютер»;Индекс = МассивТест.Найти(«Телефон»);Если Индекс ‹› Неопределено Тогда

Сообщить («Поиск завершён» + МассивТест[Индекс]);

И не забудьте поставить «завершающий оператор».

Коллекция подана для примера. Мы создали набор из трёх значений. И сделали небольшой цикл. Если утилита не найдёт подходящий элемент, она выдаст сообщение «Неопределено». Если отыщет, покажет результат.

Сортировка массива 1С просто незаменима при работе с большим объёмом данных. В них же надо как-то ориентироваться. Лучше расставить их в определённом порядке. Допустим, есть у вас коллекция «ВашМассив». Чтобы привести её «в порядок»

ТестСписок = Новый СписокЗначений;ТестСписок.ЗагрузитьЗначения(ВашМассив);ТестСписок.СортироватьПоЗначению(НаправлениеСортировки.Возр);

ВашМассив = ТестСписок.ВыгрузитьЗначения();

Вместо «Возр» можете поставить «Убыв». Также результат можно выгрузить в таблицу значений:

ТестоваяТаблица = Новый ТаблицаЗначений;ТестоваяТаблица.Колонки.Добавить(«Колонка»);ТестоваяТаблица.ЗагрузитьКолонку(ВашМассив, «Колонка»);ТестоваяТаблица.Сортировать(«Колонка Убыв»);
ВашМассив = ТестоваяТаблица.ВыгрузитьКолонку(«Колонка»)

Существуют и сложные методы сортировки: «Пузырьковая», «Быстрая», «Шейкер», «Рекурсия». У них многоуровневые и длинные алгоритмы.

Таблицы и списки

Информацию можно переправлять между разными видами коллекций. Чтобы перенести в 1С массив в таблицу значений:

МассивТелеф = Новый Массив;МассивТелеф.Добавить(«Смартфон»);МассивТелеф.Добавить(«Планшет»);МассивТелеф.Добавить(«Телефон»);ТаблицаТест = Новый ТаблицаЗначений;ТаблицаТест.Колонки.

Добавить(«Мобильники»);ТаблицаТест.Добавить();ТаблицаТест.Добавить();ТаблицаТест.Добавить();ТаблицаТест.

ЗагрузитьКолонку(МассивТелеф, «Мобильники»);Для Каждого Строка Из ТаблицаТест Цикл

Сообщить(Строка.Мобильники);

Не забудьте поставить в конце оператор завершения цикла.

Преобразовать в 1С массив в список значений совсем просто. Достаточно лишь выгрузить данные из одной коллекции в другую.

НовСписок = Новый СписокЗначений();
НовСписок.ЗагрузитьЗначения(ВашМассив);

В программировании одну проблему можно решить разными способами. И 1С — не исключение. Линейные алгоритмы, циклы, циклы с условием, циклы со счётчиком. Вариантов много. Чтобы ориентироваться в массиве, нужны некоторые навыки работы в 1С.

Источник: https://nastroyvse.ru/programs/review/kak-rabotat-s-massivami-v-1s.html

1С: что это за программа – информация для новичков

Всё о массивах в 1С: для чего нужны и как с ними работать

Здравствуйте, друзья! Мир не стоит на месте, новые технологии упрощают нашу жизнь.

Так, и программы для ведения учета и управления предприятием позволяют нам сократить время на ввод информации, хранить ее долго, при необходимости — обрабатывать и принимать на основе нее управленческие решения. В этой статье я расскажу вам об одной из самых распространенных учетных платформ. Итак, 1С: это что за программа?

Дочитав статью до конца, вы узнаете что такое «один эс-ка», в каких областях применяется, какие версии программы существуют на сегодняшний день, а также будете понимать, кому нужна данная программа, а кто может обойтись и без нее. В самом конце приведу порядок цен на самые популярные продукты 1С.

1.      1С: это что за программа? Коротко о главном.

2.      Области применения 1С

3.      ТОП-10 основных разновидностей 1С. Как выбрать подходящее прикладное решение?

4.      Почему вам, на самом деле, не нужна 1С?

5.      Порядок цен на различные прикладные решения 1С

6.      Современные технологии: 1С в мобильном

1С: это что за программа? Коротко о главном.

Впервые я познакомилась с программой 1С еще в университете. Поскольку я училась на бухгалтера, по долгу «службы» мне было положено знать данный продукт. Но с тех пор многое поменялось.

Сегодня 1С – это мощный инструмент для упрощения бизнес-процессов предприятия. Разновидностей данной программы не очень много, тяжело ошибиться с подходящей для вас конфигурацией.

Но есть и такие «индивидуумы», которые приобретают данную программу, не задумываясь о том, что данная платформа вовсе не подходит для целей и задач предприятия.

Поэтому, прежде чем выкладывать кругленькую сумму за данное программное обеспечение (ПО), я рекомендую сначала тщательно разобраться «в себе», понять, какие задачи вы бы хотели решить с помощью 1С, выбрать подходящее решение, и только потом приобретать его.

На самом деле, помимо 1С, в современном мире существует множество других управленческо-учетных программ: Мой склад, ИнфоПредприятие, SAP (немецкая), программы СКБ Контур и многие другие.

В конце концов – старый добрый Excel тоже может быть «заточен» под нужды предприятия, но тогда возникнут проблемы с автоматизацией процессов.

В свою очередь 1С, несомненно, является лидером российского рынка ПО для учета.

О типах прикладных решений

Открывая любую современную вакансию (менеджер, бухгалтер, экономист, руководитель), мы видим требование: «знание 1С». Хорошо, если указано, какую именно 1С нужно знать, какие области программы будут использоваться в работе.

Например, 1С: Бухгалтерия и 1С: КОРП рядом «не стоЯт».

Именно поэтому формулировка «знание 1С» без уточнения – это все равно, что писать «умение пользоваться кофеваркой»: какой – капельной, гейзерной, туркой или френч-прессом (хотя, последний вариант – это, скорее, «кофеЗАварка»)?

Также, хочу заострить ваше внимание на том, что типовую конфигурацию 1С в чистом виде сейчас редко кто применяет. Чаще всего, предприятия нанимают программистов для того, чтобы «переписывать» ПО под свои нужды.

Так, например, в столь крупной компании, как «ПРОДУКТЫ ЕРМОЛИНО» (в которой мне посчастливилось работать), даже есть целый отдел, который занимается адаптацией 1С под нужды Холдинга.

Также «разработку под вас» можно заказать и у самих продавцов 1С.

Именно поэтому знание конкретной конфигурации 1С не гарантирует, что вы сможете сразу начать работать в ней, т.к. она может оказаться совсем не похожа на привычную для вас версию программы.

Хотелось бы дополнить, что в наше время возможно применение как версий 1С в коробке с установкой на ПК, так и «облачных» версий 1С, т.е. онлайн-вариант работы и хранения информации (технология 1cFresh).

Однако нужно понимать, что технологической платформой для всех прикладных решений является 1С: Предприятие 8.

Области применения 1С

Вот мы и узнали, 1С — это что за программа. Перейдем к областям применения данного ПО. Если укрупнено разбить все конфигурации 1С по областям применения мы выясним, что 1С необходима для:

— ведения бухгалтерского и управленческого учета;

— составления отчетности;

— учета труда и з/п;

— управления предприятием;

— автоматизации процессов, в т.ч. торговли;

— планирования, бюджетирования.

Разработчики позаботились о том, чтобы для бюджетных и коммерческих организаций были разные — «свои» прикладные решения.

Также необходимо учитывать, что для вашего типа бизнеса уже может быть разработано специализированное отраслевое решение. На сегодняшний день есть возможность приобрести следующие ПО:

Вы можете подобрать подходящее для вас отраслевое программное обеспечение по этой ссылке.

ТОП-10 основных разновидностей 1С. Как выбрать подходящее прикладное решение?

На рисунке ниже в рамку я выделила самые распространенные ПР (прикладные решения) для 1С.

Название каждого ПР говорит само за себя. На этапе выбора программного обеспечения вы уже должны понимать, для чего вам нужна программа 1С. Так, если задачей является приобретение программы для бухгалтерского учета и отчетности – как нельзя лучше подойдет 1С: Бухгалтерия 8.

Если вы хотите приобрести ПО для облегчения работы Отдела кадров, вам подойдет ЗУП (1С: Зарплата и управление персоналом).

Чтобы выбрать подходящую вам программу ответьте на следующие вопросы:

Данную информацию необходимо будет сообщить продавцу программы, чтобы он смог порекомендовать вам оптимальное решение. Также важно учитывать необходимость автоматизации процессов, то, какое оборудование вы будете подключать, есть ли у вас маркировочный товар и проч.

Кстати, сервис «solutions« поможет подобрать ПО, если вы понимаете, какие задачи вы хотите решить с помощью 1С:

Почему вам, на самом деле, не нужна 1С?

Если вы спросите, применяю ли я 1С для своих предприятий (магазины продуктов, мебельное производство и бухгалтерский аутсорсинг), то я отвечу – не для всех видов бизнеса. И вот почему:

Вам может не понадобиться 1С (и любая другая учетная программа), если:

вы работаете один: нет необходимости проводить контрольные мероприятия;

— у вас маленький бизнес: допустим, у вас – ремонт обуви, в таком случае не стоит приобретать дорогостоящую программу;

— вы находитесь на патенте, ЕНВД, УСН, или применяете налог на проф.

деятельность (являетесь самозанятым гражданином) – ведение учета на патенте и НПД вообще необязательно, а на ЕНВД и УСН при небольших оборотах можно вести учет в ручную, например, в Excel, главное – вовремя сдавать отчеты, для этого можно использовать, например, бесплатную программу «Налогоплательщик ЮЛ»;

— вы отлично справляетесь и без нее – если вы сами не видите необходимости в данной программе;

— вам не нужна автоматизация процессов – если у вас небольшой список номенклатуры, мало продаж.

Никто не может обязать вас применять учетную программу. Вы сами решаете для себя, нужна ли она вашему предприятию.

Также существуют бесплатные учетные программы типа Мой склад и ИнфоПредприятие, которые имеют ограниченную функциональность. Но ее может быть достаточно для вашего бизнеса. Ознакомьтесь с ними, вероятно, эти программы вам подойдут.

Порядок цен на различные прикладные решения 1С

Теперь давайте посмотрим, во что нам обойдется приобретение столь прекрасного программного продукта, как 1С.

Есть возможность скачать «сломанную» версию на каком-нибудь сайте софта. Но тут есть опасность схватить вирус, нарваться на нерабочую версию, и, разумеется, ни о какой поддержке уж точно говорить не приходится. Поэтому, я не рекомендую данный вариант.

Рассчитать стоимость 1С самостоятельно можно по ссылке.

Но для ознакомления я привожу примерный порядок цен. Естественно, он может отличаться у разных поставщиков продукта. Смотрите также, чтобы поставщик был аккредитован самим 1С.

Лицензия на 1 рабочее место может варьироваться от 6 300 руб. до 10 500 руб. в зависимости от типа приобретаемого ПО. Чем больше лицензий, тем они дешевле обходятся. Лицензии для дочерних предприятий Холдингов продаются пакетами стоимостью порядка 200 000 руб.

Также необходимо учесть, что электронная поставка 1С бывает значительно дешевле, чем версия в коробке.

По состоянию на 01.03.19 имеется примерно следующий порядок цен:

К сожалению, не всегда базовая версия программы сможет решить все необходимые задачи, будьте к этому готовы.

Каждое ПР призвано решать определенный круг задач. Так, например, 1С Розница содержит в себе следующие блоки:

В любом случае, многое ПО 1С можно протестировать в демо-режиме: понравится или нет.

Современные технологии: 1С в мобильном

В конце 2018 года я участвовала в конференции 1С, посвященной увеличению роста прибыли современного предприятия. Одной из важнейших тем стала автоматизации бизнес-процессов.

Посмотреть видео с конференции можно тут (в конце страницы).

Так вот, оказывается, сегодня 1С предлагает не только десктоп- и онлайн-версии, но и решения для мобильных телефонов:

Более подробно с ними можно ознакомиться тут.

Стоимость клиентских лицензий для мобильных гораздо ниже, чем для ПК – 1 200 руб. вместо 6 300 руб.

Причем, вы самостоятельно можете создавать мобильные приложения на базе 1С под свои потребности.

Вот это видео показывает, как это можно сделать. Сама не пробовала, но специалисты 1С утверждают, что справляются даже студенты.

А тут вы можете увидеть, как применяются современные мобильные технологии 1С (это выдержка с конференции, специалист волнуется, но в целом – все понятно).

Источник: https://bizhelp.su/1s-eto-chto-za-programma/

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.